Discussion:
Grafikkartentreiber
(zu alt für eine Antwort)
Daniel Wachter
2017-06-28 14:16:27 UTC
Permalink
Raw Message
OpenSUSE 42.2
Xfce
Prozessor: i5-7500

Gruß zuvor!
Wir haben einen neuen Rechner mit dem Prozessor i5-7500. Wir wollen ihn
mit der on-board Grafik, ohne extra Grafikkarte betreiben. Aber wenn wir
den Bildschirm über DVI anschließen wird uns nur die Auflösung 1024x768
angeboten. Die on-board Grafik müßte schon mehr können, oder? Woran kann
das liegen? Der Hersteller hat uns empfohlen, den Grafikkartentreiber zu
aktualisieren. Der ist aber im OpenSUSE enthalten, oder? xorg-x11 haben
wir installiert.

Gruß, Daniel
Bernd Schwegmann
2017-06-28 20:21:18 UTC
Permalink
Raw Message
Post by Daniel Wachter
OpenSUSE 42.2
Xfce
Prozessor: i5-7500
Gruß zuvor!
Wir haben einen neuen Rechner mit dem Prozessor i5-7500. Wir wollen ihn
mit der on-board Grafik, ohne extra Grafikkarte betreiben. Aber wenn wir
den Bildschirm über DVI anschließen wird uns nur die Auflösung 1024x768
angeboten. Die on-board Grafik müßte schon mehr können, oder? Woran kann
das liegen? Der Hersteller hat uns empfohlen, den Grafikkartentreiber zu
aktualisieren. Der ist aber im OpenSUSE enthalten, oder? xorg-x11 haben
wir installiert.
Ich hab gleiche CPU im neuen Rechner. Nimm HDMI-Kabel, der Monitor muß
natürlich das auch anbieten. Hier läuft 32" Benq mit
2560X1440 bei 60Hz. GPU Prozessor Intel auf Mainboard z630.
mit Ubuntu 17.04

BS
Arno Lutz
2017-06-28 20:28:51 UTC
Permalink
Raw Message
Hallo Bernd Schwegmann,
Post by Bernd Schwegmann
Nimm HDMI-Kabel,
das setzt dann voraus die die Grafikeinheit mit im Gehäuse des Screens ist.
Folglich wärs _dann_ egal was für GraKa im PC sitzt.
Setzt aber im Umkehrschluss voraus, dass der PC HDMI _hat_!

Gruß
Arno Lutz
--
Jeder hat dumme Gedanken, nur der Kluge verschweigt sie.
Daniel Wachter
2017-06-29 07:52:04 UTC
Permalink
Raw Message
Post by Bernd Schwegmann
Ich hab gleiche CPU im neuen Rechner. Nimm HDMI-Kabel,
Der Monitor hat nur einen DVI- und einen VGA-Anschluß. Ist schon ein
älteres Modell, wird aber in der Hardwareliste richtig mit 1900x1200
angezeigt. Früher gab es doch im Yast eine Abteilung Grafik/Monitor,
aber jetzt finde ich da nichts. In den Monitoreinstellungen im Xfce wird
der Hersteller des Monitors nicht erkannt. Wo kann man denn per Hand die
Auflösung einstellen?
Daniel
Bernd Schwegmann
2017-06-29 21:27:31 UTC
Permalink
Raw Message
Post by Daniel Wachter
Post by Bernd Schwegmann
Ich hab gleiche CPU im neuen Rechner. Nimm HDMI-Kabel,
Der Monitor hat nur einen DVI- und einen VGA-Anschluß. Ist schon ein
älteres Modell, wird aber in der Hardwareliste richtig mit 1900x1200
angezeigt. Früher gab es doch im Yast eine Abteilung Grafik/Monitor,
aber jetzt finde ich da nichts. In den Monitoreinstellungen im Xfce wird
der Hersteller des Monitors nicht erkannt. Wo kann man denn per Hand die
Auflösung einstellen?
Daniel
Sorry, aber ich hätte deutlicher betonen sollen, daß die
Intel-Main-Board HD-Grafik z630 ist. Die kann 2600 x 1500 dpi NUR per HDMI
übertragen, außerdem hab ich hier Ubuntu 17.04, zu SuSe kann ich nichts
sagen. Nochmals sri! IMHO kann das DVI-Interface nur 1900 x 1200 +60Hz.


Groetjes BS+
Daniel Wachter
2017-06-30 12:55:26 UTC
Permalink
Raw Message
Post by Bernd Schwegmann
Sorry, aber ich hätte deutlicher betonen sollen, daß die
Intel-Main-Board HD-Grafik z630 ist. Die kann 2600 x 1500 dpi NUR per HDMI
übertragen, außerdem hab ich hier Ubuntu 17.04, zu SuSe kann ich nichts
sagen. Nochmals sri! IMHO kann das DVI-Interface nur 1900 x 1200 +60Hz.
Genau das brauche ich ja. Also wie kann ich jetzt diese Auflösung
einstellen, wenn sie mir in den Monitoreinstellungen von Xfce nicht
angeboten wird, obwohl im Yast in der Hardwareliste der Bildschirm
richtig (mit Hersteller und Auflösung) erkannt wird?
Daniel
Dieter Intas
2017-06-30 13:46:19 UTC
Permalink
Raw Message
Am Fri, 30 Jun 2017 14:55:26 +0200
Post by Daniel Wachter
Post by Bernd Schwegmann
Sorry, aber ich hätte deutlicher betonen sollen, daß die
Intel-Main-Board HD-Grafik z630 ist. Die kann 2600 x 1500 dpi NUR
per HDMI übertragen, außerdem hab ich hier Ubuntu 17.04, zu SuSe
kann ich nichts sagen. Nochmals sri! IMHO kann das DVI-Interface
nur 1900 x 1200 +60Hz.
Genau das brauche ich ja. Also wie kann ich jetzt diese Auflösung
einstellen, wenn sie mir in den Monitoreinstellungen von Xfce nicht
angeboten wird, obwohl im Yast in der Hardwareliste der Bildschirm
richtig (mit Hersteller und Auflösung) erkannt wird?
Daniel
Über die XRandR-Erweiterung des XServers und den Befehl xrandr kann
man auch die Auflösung des Bildschirms ändern. Mit der Option -s oder
mit --size kann die gewünschte Auflösung angegeben werden.

Zum Beispiel:

Der folgende Befehl setzt die Bildschirmauflösung auf 1900 x 1200 +60Hz

***@name:~$ xrandr -s 1900x1200

Um die Wiederholrate auf 60 Hz zu setzen

***@name:~$ xrandr -r 60

Du solltest doch auch sicher sein, dass Dein Moni das auch bringt!

Schau Dir mal mit "***@name:~$ man xrandr" genauer an.
Daniel Wachter
2017-06-30 14:48:02 UTC
Permalink
Raw Message
Post by Dieter Intas
Über die XRandR-Erweiterung des XServers und den Befehl xrandr kann
man auch die Auflösung des Bildschirms ändern. Mit der Option -s oder
mit --size kann die gewünschte Auflösung angegeben werden.
Der folgende Befehl setzt die Bildschirmauflösung auf 1900 x 1200 +60Hz
Danke. In der Yast-Hardwareliste wird 1920x1200 angegeben, aber wenn ich

xrandr -s 1920x1200

eingebe, kommt

"Size 1920x1200 not found in available modes"

Woran kann das liegen? Nochmal die Hardware:
Bildschirm HP L2445w, 1920x1200 bei 60 Hz
Intel i5-7500 3.40 GHz

Daniel
Dieter Intas
2017-06-30 15:06:40 UTC
Permalink
Raw Message
Am Fri, 30 Jun 2017 16:48:02 +0200
Post by Daniel Wachter
Post by Dieter Intas
Über die XRandR-Erweiterung des XServers und den Befehl xrandr kann
man auch die Auflösung des Bildschirms ändern. Mit der Option -s
oder mit --size kann die gewünschte Auflösung angegeben werden.
Der folgende Befehl setzt die Bildschirmauflösung auf 1900 x 1200
Danke. In der Yast-Hardwareliste wird 1920x1200 angegeben, aber wenn ich
xrandr -s 1920x1200
eingebe, kommt
"Size 1920x1200 not found in available modes"
Nun - ist nicht in der Liste - siehe xrandr
Post by Daniel Wachter
Bildschirm HP L2445w, 1920x1200 bei 60 Hz
Intel i5-7500 3.40 GHz
Kann man möglicherweise erzwingen - aber das ist außer meinem Bereich.

Vielleicht kann Dir in der news:de.comp.os.unix.linux.misc weiter
geholfen werden.
Daniel Wachter
2017-07-01 16:27:13 UTC
Permalink
Raw Message
Post by Dieter Intas
Vielleicht kann Dir in der news:de.comp.os.unix.linux.misc weiter
geholfen werden.
Danke, da habe ich nun angefragt und meine Xorg.0.log gepostet.

Andreas, xrandr ergibt nur, daß da eben etwas fehlt.

Daniel
Dieter Intas
2017-07-01 17:31:51 UTC
Permalink
Raw Message
Am Sat, 1 Jul 2017 18:27:13 +0200
Post by Daniel Wachter
Post by Dieter Intas
Vielleicht kann Dir in der news:de.comp.os.unix.linux.misc weiter
geholfen werden.
Danke, da habe ich nun angefragt und meine Xorg.0.log gepostet.
Na schön.
Post by Daniel Wachter
Andreas, xrandr ergibt nur, daß da eben etwas fehlt.
Nanü - Du weißt das etwas fehlt - nur Du weißt nicht was fehlt!?

Woher weißt Du das überhaupt was fehlt?

Kannst Du die Ausgabe von xrandr mal posten?
Daniel Wachter
2017-07-01 19:05:01 UTC
Permalink
Raw Message
Problem gelöst: Der Kernel 4.4 hat den Prozessor nicht unterstützt.
Nachdem ich 4.9 installiert hatte, ging alles!
Daniel
Dieter Intas
2017-07-01 19:21:40 UTC
Permalink
Raw Message
Am Sat, 1 Jul 2017 21:05:01 +0200
Post by Daniel Wachter
Problem gelöst: Der Kernel 4.4 hat den Prozessor nicht unterstützt.
Nachdem ich 4.9 installiert hatte, ging alles!
Daniel
Schön - wie auch immer - einen offiziellen Kernel 4.9.xxx für Leap 42.2
gibt es nicht. Aber wenn es läuft, dann ist ja OK.
Daniel Wachter
2017-07-01 19:37:47 UTC
Permalink
Raw Message
Post by Dieter Intas
Am Sat, 1 Jul 2017 21:05:01 +0200
Post by Daniel Wachter
Problem gelöst: Der Kernel 4.4 hat den Prozessor nicht unterstützt.
Nachdem ich 4.9 installiert hatte, ging alles!
Daniel
Schön - wie auch immer - einen offiziellen Kernel 4.9.xxx für Leap 42.2
gibt es nicht. Aber wenn es läuft, dann ist ja OK.
Habe halt einen von https://software.opensuse.org/search genommen. Bin
froh, daß ich da einen gefunden habe, offiziell oder nicht.
Daniel
Werner Flamme
2017-07-03 09:33:33 UTC
Permalink
Raw Message
Post by Daniel Wachter
Problem gelöst: Der Kernel 4.4 hat den Prozessor nicht unterstützt.
Nachdem ich 4.9 installiert hatte, ging alles!
Daniel
Nimm doch gleich den Kernel aus
<http://download.opensuse.org/repositories/Kernel:/stable/standard/>,
der ist immer aktuell.


--

Andreas Hartmann
2017-06-30 17:24:03 UTC
Permalink
Raw Message
Post by Daniel Wachter
Post by Dieter Intas
Über die XRandR-Erweiterung des XServers und den Befehl xrandr kann
man auch die Auflösung des Bildschirms ändern. Mit der Option -s oder
mit --size kann die gewünschte Auflösung angegeben werden.
Der folgende Befehl setzt die Bildschirmauflösung auf 1900 x 1200 +60Hz
Danke. In der Yast-Hardwareliste wird 1920x1200 angegeben, aber wenn ich
xrandr -s 1920x1200
eingebe, kommt
"Size 1920x1200 not found in available modes"
grep Modeline /var/log/Xorg.0.log

hilft weiter, wenn Du wissen willst, was Dein Monitor / Graka beherrscht.

Gruß,
Andreas
Andreas Hartmann
2017-06-30 17:27:43 UTC
Permalink
Raw Message
Post by Andreas Hartmann
Post by Daniel Wachter
Post by Dieter Intas
Über die XRandR-Erweiterung des XServers und den Befehl xrandr kann
man auch die Auflösung des Bildschirms ändern. Mit der Option -s oder
mit --size kann die gewünschte Auflösung angegeben werden.
Der folgende Befehl setzt die Bildschirmauflösung auf 1900 x 1200 +60Hz
Danke. In der Yast-Hardwareliste wird 1920x1200 angegeben, aber wenn ich
xrandr -s 1920x1200
eingebe, kommt
"Size 1920x1200 not found in available modes"
grep Modeline /var/log/Xorg.0.log
hilft weiter, wenn Du wissen willst, was Dein Monitor / Graka beherrscht.
oder einfach nur

xrandr

ist auch hilfreich
Post by Andreas Hartmann
Gruß,
Andreas
Loading...