Discussion:
Windows starten nach Leap-Installation
(zu alt für eine Antwort)
Alexander Goetzenstein
2016-06-29 06:24:31 UTC
Permalink
Raw Message
Hallo,
wenn man etwas nur alle halbe Jahrzehnte macht, vergisst man gern die
Hälfte:

Anlässlich der Leap-Installation habe ich mir eine neue (größere)
Festplatte gegönnt. Vorbereitend habe ich die (primären)
Windows-Partitionen zylindergleich angelegt und die für Linux
vorgesehenen entsprechend großzügiger. Anschließend habe ich die
Windows-Partitionen (einmal die Wiederherstellungs-Partition von Lenovo
und einmal die eigentlich produktive mit Windows7) mit dd auf die neue
Platte gebracht. Anschließend habe ich dann unter Bestätigung der
Defaults Leap installiert. Grub2 landete dabei im MBR, wie mir yast
versichert. Im Boot-Menü sind auch brav alle Systeme (openSUSE Leap
(standard und erweitert), Windows von sda1 und Windows von sda2)
aufgeführt. Wenn ich jedoch Windows (sda2 ist das normale Windows7)
wähle, bekomme ich nur einen schwarzen Bildschirm statt Windows.

Was läuft falsch, was habe ich vergessen oder übersehen, wie mache ich
es richtig?
--
Gruß
Alex
Werner Flamme
2016-06-29 06:41:21 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Hallo,
wenn man etwas nur alle halbe Jahrzehnte macht, vergisst man gern die
Anlässlich der Leap-Installation habe ich mir eine neue (größere)
Festplatte gegönnt. Vorbereitend habe ich die (primären)
Windows-Partitionen zylindergleich angelegt und die für Linux
vorgesehenen entsprechend großzügiger. Anschließend habe ich die
Windows-Partitionen (einmal die Wiederherstellungs-Partition von Lenovo
und einmal die eigentlich produktive mit Windows7) mit dd auf die neue
Platte gebracht. Anschließend habe ich dann unter Bestätigung der
Defaults Leap installiert. Grub2 landete dabei im MBR, wie mir yast
versichert. Im Boot-Menü sind auch brav alle Systeme (openSUSE Leap
(standard und erweitert), Windows von sda1 und Windows von sda2)
aufgeführt. Wenn ich jedoch Windows (sda2 ist das normale Windows7)
wähle, bekomme ich nur einen schwarzen Bildschirm statt Windows.
Was läuft falsch, was habe ich vergessen oder übersehen, wie mache ich
es richtig?
Ich übernehme ich solchen Fällen per dd die gesamte Platte und ändere
hinterher die Partitionstabelle per fdisk oder gdisk. Oder ich nehme
gleich Clonezilla. Bei beiden Verfahren hatte ich noch keine Probleme.

Gruß
Werner
--
Alexander Goetzenstein
2016-06-29 20:50:34 UTC
Permalink
Raw Message
Hallo,
Post by Werner Flamme
Ich übernehme ich solchen Fällen per dd die gesamte Platte und ändere
hinterher die Partitionstabelle per fdisk oder gdisk.
nachdem mir das im Nachhinein nur noch schlecht möglich ist, bevorzuge
ich eine leichtere Lösung. Die gibt es doch bestimmt, oder?
--
Gruß
Alex
Dieter Intas
2016-06-30 05:03:44 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Post by Werner Flamme
Ich übernehme ich solchen Fällen per dd die gesamte Platte und ändere
hinterher die Partitionstabelle per fdisk oder gdisk.
nachdem mir das im Nachhinein nur noch schlecht möglich ist, bevorzuge
ich eine leichtere Lösung. Die gibt es doch bestimmt, oder?
Wie sieht denn fdisk -l aus?
Alexander Goetzenstein
2016-06-30 05:19:04 UTC
Permalink
Raw Message
Hallo,
Post by Dieter Intas
Wie sieht denn fdisk -l aus?
linux-t420:~ # fdisk -l
Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001d233
Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 2473983 2471936 1.2G 7 HPFS/NTFS/exFAT
/dev/sda2 2473984 356980735 354506752 169G 7 HPFS/NTFS/exFAT
/dev/sda3 356980736 381544447 24563712 11.7G 7 HPFS/NTFS/exFAT
/dev/sda4 381544448 3907028991 3525484544 1.7T f W95 Ext'd (LBA)
/dev/sda5 381546496 398315519 16769024 8G 82 Linux swap / Solaris
/dev/sda6 398317568 503171071 104853504 50G 83 Linux
/dev/sda7 503173120 3907008511 3403835392 1.6T 83 Linux
--
Gruß
Alex
Dieter Intas
2016-06-30 05:40:08 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Hallo,
Post by Dieter Intas
Wie sieht denn fdisk -l aus?
linux-t420:~ # fdisk -l
Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001d233
Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 2473983 2471936 1.2G 7
HPFS/NTFS/exFAT /dev/sda2 2473984 356980735 354506752
169G 7 HPFS/NTFS/exFAT /dev/sda3 356980736 381544447
24563712 11.7G 7 HPFS/NTFS/exFAT /dev/sda4 381544448
3907028991 3525484544 1.7T f W95 Ext'd (LBA) /dev/sda5
381546496 398315519 16769024 8G 82 Linux swap /
Solaris /dev/sda6 398317568 503171071 104853504 50G 83
Linux /dev/sda7 503173120 3907008511 3403835392 1.6T 83
Linux
Wäre das bei mir der Fall, dann würde ich ich unter Yast den Bootloader
starten - also einfach nur starten und dann OK - damit wird er wieder
konfiguriert und sollte nach einem Reboot auch gewünschtes wieder
booten. So bin ich jedenfalls vorgegangen, als Windows7 nicht mehr
Booten wollte und hatte Erfolg.
Alexander Goetzenstein
2016-06-30 16:39:49 UTC
Permalink
Raw Message
Hallo,
Post by Dieter Intas
Wäre das bei mir der Fall, dann würde ich ich unter Yast den Bootloader
starten - also einfach nur starten und dann OK - damit wird er wieder
konfiguriert und sollte nach einem Reboot auch gewünschtes wieder
booten. So bin ich jedenfalls vorgegangen, als Windows7 nicht mehr
Booten wollte und hatte Erfolg.
leider hilft das bei mir nicht.
Ich würde ja gern mal einsehen, was yast denn da so fabriziert hat, aber
es verbirgt so gut wie alle Details vor mir. Früher™ gab es da ja mal
eine Textdatei, die man lesen und editieren konnte, aber diese Zeiten
sind wohl schon länger vorbei, eine Manpage gibt es nicht, und der
ergoogelte grub2-Editor tut nicht. Wie kann ich mich der Sache nähern?
--
Gruß
Alex
Dieter Intas
2016-06-30 18:09:35 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Hallo,
Post by Dieter Intas
Wäre das bei mir der Fall, dann würde ich ich unter Yast den
Bootloader starten - also einfach nur starten und dann OK - damit
wird er wieder konfiguriert und sollte nach einem Reboot auch
gewünschtes wieder booten. So bin ich jedenfalls vorgegangen, als
Windows7 nicht mehr Booten wollte und hatte Erfolg.
leider hilft das bei mir nicht.
Ich würde ja gern mal einsehen, was yast denn da so fabriziert hat,
aber es verbirgt so gut wie alle Details vor mir. Früher™ gab es da ja
mal eine Textdatei, die man lesen und editieren konnte, aber diese
Zeiten sind wohl schon länger vorbei, eine Manpage gibt es nicht, und
der ergoogelte grub2-Editor tut nicht. Wie kann ich mich der Sache
nähern?
Vielleicht mal im Bios schauen - die Secure-Boot-Funktion abschalten.
Der Ausschalter steckt im BIOS-Setup, pardon, im UEFI-Firmware-Setup
des jeweiligen Systems. Falls man das Setup nicht mit üblichen Tasten
beim Systemstart erreicht – Entf, F2, siehe Handbuch –, lässt es sich
bei Windows-8-Rechnern sogar vom Betriebssystem aus aufrufen.

kenne dein Bios nicht, aber man sollte nichts machen, wenn man nicht
weiß was man tut bzw. die Hilfe lesen.
Alexander Goetzenstein
2016-07-01 05:29:12 UTC
Permalink
Raw Message
Hallo,
Post by Dieter Intas
Vielleicht mal im Bios schauen - die Secure-Boot-Funktion abschalten.
sowas hat mein BIOS gar nicht. Neumodischer Kram... ;-)
Außerdem habe ich daran nicht gefummelt, sondern nur an der Platte.
--
Gruß
Alex
Dieter Intas
2016-07-01 06:43:34 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Hallo,
Post by Dieter Intas
Vielleicht mal im Bios schauen - die Secure-Boot-Funktion
abschalten.
sowas hat mein BIOS gar nicht. Neumodischer Kram... ;-)
Außerdem habe ich daran nicht gefummelt, sondern nur an der Platte.
Wenn du im Grub2-Menü nun Windows7 bootest - gibt es, außer
schwarzen Bildschirm, noch vorher Ausgaben - ansonsten sehe ich
da ein eher Grafik-Problem ...

Kann es sein das Windows7 bootet, aber nur mit schwarzen Bildschirm?
Alexander Goetzenstein
2016-07-01 12:05:07 UTC
Permalink
Raw Message
Hallo,
Post by Dieter Intas
Wenn du im Grub2-Menü nun Windows7 bootest - gibt es, außer
schwarzen Bildschirm, noch vorher Ausgaben - ansonsten sehe ich
da ein eher Grafik-Problem ...
das würde mich wundern, habe ich doch weder an Windows noch an der
Hardware irgendetwas geändert -bis eben auf die Festplatte.
Post by Dieter Intas
Kann es sein das Windows7 bootet, aber nur mit schwarzen Bildschirm?
Nun, es ist unmittelbar (sofort) ein blinkender Textcursor zu sehen, und
[Strg]+[Alt]+[Entf] bootet sofort. Viel Windows kann da noch nicht
gebootet haben, ich vermute: gar nichts. Für mich sieht es so aus, dass
der Bootvorgang an eine Adresse auf der Platte übergeben wird, die so
einfach nicht bootet. Wenn das so ist, müsste es mit einer korrigierten
Bootmanager-Konfig zu reparieren sein. Vielleicht muss auch nur etwas in
der Partitionierung repariert werden?
--
Gruß
Alex
Markus Grob
2016-07-01 12:24:21 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Hallo,
Post by Dieter Intas
Wie sieht denn fdisk -l aus?
linux-t420:~ # fdisk -l
Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001d233
Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 2473983 2471936 1.2G 7 HPFS/NTFS/exFAT
/dev/sda2 2473984 356980735 354506752 169G 7 HPFS/NTFS/exFAT
Müsste das Boot-Flag nicht auf sda2 für Windows gesetzt sein? Die erste
Partition schaut nach dem Rescue-System aus.

Gruss, Markus
Alexander Goetzenstein
2016-07-01 20:29:02 UTC
Permalink
Raw Message
Hallo,
Post by Markus Grob
Müsste das Boot-Flag nicht auf sda2 für Windows gesetzt sein? Die erste
Partition schaut nach dem Rescue-System aus.
nö, das nicht. Aber Dein Hinweis hat mich trotzdem weitergebracht: es
handelt sich wohl um eine Art Boot-Partition, die wohl nicht
funktionierte. Ich habe sie noch einmal dd zum Fraß vorgeworfen, und
jetzt bootet Windows. Was auch immer Lenovo da konstruiert hat, ich
verstehe es nicht. Aber immerhin läuft es jetzt. Danke.
--
Gruß
Alex
Alexander Goetzenstein
2017-05-20 15:32:24 UTC
Permalink
Raw Message
Hallo,
Post by Alexander Goetzenstein
Post by Markus Grob
Müsste das Boot-Flag nicht auf sda2 für Windows gesetzt sein? Die erste
Partition schaut nach dem Rescue-System aus.
nö, das nicht. Aber Dein Hinweis hat mich trotzdem weitergebracht: es
handelt sich wohl um eine Art Boot-Partition, die wohl nicht
funktionierte. Ich habe sie noch einmal dd zum Fraß vorgeworfen, und
jetzt bootet Windows. Was auch immer Lenovo da konstruiert hat, ich
verstehe es nicht. Aber immerhin läuft es jetzt. Danke.
um ehrlich zu sein, erinnere ich mich nicht mehr, was da letztes Jahr
war, noch nicht einmal daran, dass Windows tatsächlich gestartet hat,
seitdem habe ich Windows auch nicht mehr starten wollen. Jetzt aber
schon, und siehe da: ich bin wieder an der Stelle mit dem Problem, dass
Windows nicht bootet: aus /dev/sda2 sehe ich nur einen blinkenden
Textcursor, und aus /dev/sda1 gebootet erscheint folgender Bildschirm
Post by Alexander Goetzenstein
[ Windows-Start-Manager ]
Fehler beim Start von Windows. Die Ursache dafür ist eventuell eine kürzlich
1. Legen Sie die Windows-CD/DVD ein, und starten Sie den Computer neu.
2. Wählen Sie die Spracheinstellungen aus, und klicken Sie dann auf "Weiter".
3. Klicken sie auf "Computer reparieren".
Wenn Sie diesen Datenträger nicht besitzen, wenden Sie sich an den
Systemadministrator oder den Computerhersteller.
Status: 0xc000000e
Info: Fehler bei Startauswahl. Zugriff auf ein erforderliches Gerät
nicht möglich.
[ ESC=Beenden ]
Muss ich dazu zwingend bei Lenovo einen Datenträger bestellen, oder kann
man das auch mit SuSE Leap reparieren? Ich vermute ja, dass die
Partition nur so markiert werden müsste, dass nicht nur grub2, sondern
auch Windows das versteht. Oder so ähnlich...
--
Gruß
Alex
Markus Grob
2017-05-28 09:31:44 UTC
Permalink
Raw Message
Post by Alexander Goetzenstein
Status: 0xc000000e
Mit windows und boot führt das zu folgendem Link. Evtl. bekommst Du dort
die notwendigen Infos:

https://answers.microsoft.com/en-us/windows/forum/all/0xc000000e-boot-error/ef08ab00-e130-4301-bc80-79d5b414a81f

Gruss, Markus

Thomas Mueller
2016-06-30 17:31:24 UTC
Permalink
Raw Message
Am Wed, 29 Jun 2016 22:50:34 +0200
Post by Alexander Goetzenstein
Hallo,
Post by Werner Flamme
Ich übernehme ich solchen Fällen per dd die gesamte Platte und
ändere hinterher die Partitionstabelle per fdisk oder gdisk.
nachdem mir das im Nachhinein nur noch schlecht möglich ist,
bevorzuge ich eine leichtere Lösung. Die gibt es doch bestimmt, oder?
Super-Grub2-Disk bootet so ziemlich alle Betriebssystem, die sich auf
der Festplatte befinden (hat bei mir bisher immer funktioniert und
lässt dann Reparaturwege aus dem laufenden System zu). Lässt sich von CD
oder USB-Stick booten und auf http://www.supergrubdisk.org/ finden.
In Rescatux mit erweiterten Möglichkeiten ist Super-Grub2-Disk
ebenfalls enthalten. Viel Erfolg
Alexander Goetzenstein
2016-07-01 20:30:08 UTC
Permalink
Raw Message
Hallo,
Post by Thomas Mueller
Super-Grub2-Disk bootet so ziemlich alle Betriebssystem, die sich auf
der Festplatte befinden (hat bei mir bisher immer funktioniert und
lässt dann Reparaturwege aus dem laufenden System zu). Lässt sich von CD
oder USB-Stick booten und aufhttp://www.supergrubdisk.org/ finden.
In Rescatux mit erweiterten Möglichkeiten ist Super-Grub2-Disk
ebenfalls enthalten. Viel Erfolg
Danke, sieht interessant aus. Habe es heruntergeladen, brauche es aber
nicht mehr. Ich hebe es mir aber fürs nächste mal auf.
--
Gruß
Alex
Loading...